Viofo A129 Android App - trouble connecting

dmichaels

New Member
Joined
Aug 29, 2018
Messages
1
Points
1
I'm sure it's just me...I can connect to the Viofo Wi-Fi. My phone says "Connected, No Internet"
- I think that's expected. But I still have trouble connecting the app to the A129.
What am I doing wrong? (or not doing?)

Also, is there an application that runs on a PC to connect to the A129?
 

VIOFO-Swin

New Member
Joined
Sep 4, 2018
Messages
57
Points
3
May I know the details of "trouble connecting the app to A129"?
We don't have the application which can runs on PC to connect to the A129 at present.
 

viofo

Administrator
Staff member
Joined
May 30, 2018
Messages
415
Points
28
Please try to only use the 2.4G Wi-Fi option, if not OK, try to disable the phone 4G data service.
 

Zomaxx

New Member
Joined
Oct 27, 2018
Messages
6
Points
3
In my case: I have removed all my the known internet connections (home, office) in the phone settings that were connected previously with passwords. It looks the phone try to connect to a better wifi connections and throw away the camera 72 Mbit/s connection....
Have a try...
 

viofo

Administrator
Staff member
Joined
May 30, 2018
Messages
415
Points
28
For a stronger connection, please try 5G connection.
 

slbrown63

New Member
Joined
Mar 13, 2019
Messages
1
Points
1
I recently purchased/ installed my A129 in my truck which has built-in WiFi as well. I was proud of the installation and looked forward to using the App w/ the camera. I downloaded the App to my Google Pixel XL phone (Android). Now I am having problems getting a connection either in my truck or from the house.

I checked my camera settings thinking that may be the cause of my connectivity problems. I tried turning the camera off/on, but still no connection to the App on my cell. My A129 Duo seems to connect once I got into my truck or after I turned off/on the camera. I read several of replies here with various troubleshooting solution(s), but I think most of them I tried.

I tried turning on/off the WiFi button on the camera and it displayed the WiFi symbol with an hour glass symbol which made me think that it is waiting on something to happen. Bottom Line- Should I turn my WiFi off when my truck is parked w/ the parking mode on? Does distance affect connectivity of App if I am trying to view LIVE SOURCE feed at work or home? I understand that this issue may have been responded to in the past, but what is the best solution?
 

Ubershopper

New Member
Joined
Mar 17, 2019
Messages
13
Points
3
I have been having connectivity problems too and don't have any consistent method of connecting. It fails to connect more often than it succeeds. I also have a pixel 3 XL.
 

VignaleIan

New Member
Joined
Mar 19, 2019
Messages
2
Points
3
I have just powered up my new A129, all appears to be functioning but I cannot access the menu through the phone connection. I cannot even get the menu up using the buttons on the A129, what is wrong? It has been a long job hiding all the cables, the cost has not been cheap either. Can anyone suggest something to help? I will contact Viofo with regards this problem and give it to the end of the week, if it isn't up and running it will be removed and sent back as not fit for purpose. I hope someone can help, there must be others that have come across this same problem. Thanks in advance to anyone that can help.
 

Capture Your Action

Well-Known Member
Joined
Feb 24, 2019
Messages
1,430
Points
63
I have just powered up my new A129, all appears to be functioning but I cannot access the menu through the phone connection. I cannot even get the menu up using the buttons on the A129, what is wrong? It has been a long job hiding all the cables, the cost has not been cheap either. Can anyone suggest something to help? I will contact Viofo with regards this problem and give it to the end of the week, if it isn't up and running it will be removed and sent back as not fit for purpose. I hope someone can help, there must be others that have come across this same problem. Thanks in advance to anyone that can help.
If WiFi is on, you will not be able to use the buttons on the camera itself. WiFi must be turned off for camera buttons to function
 

VignaleIan

New Member
Joined
Mar 19, 2019
Messages
2
Points
3
Thanks for your reply, just been out to it and turned WiFi off and entered the menu, Spot on. It is now dark so I will have another look in the daylight tomorrow.
Thanks for your prompt reply.
 

BCHobbyist

Member
Joined
Mar 18, 2019
Messages
30
Points
8
Location
Vancouver, Canada
Website
viofo-dash-cam-selection-advice.blogspot.com
WiFi Dashcam control in one way is a gimmick, it isn't required but a convenience and very helpful for Lens angle adjustment, settings and retrieving crash footage on scene otherwise never use it while Driving for the following reasons:
  • when WiFi is enabled it throttles video Bitrate from 16-20 Mbps down to 8 Mbps with Rear camera connected which greatly reduces image detail to maintain LiveView streaming connection.
  • when WiFi is enabled it generates more heat using more power not good on hot summer days.
  • WiFi connections can drop out frequently especially with other Access Points nearby or smartphone Auto connecting to other networks.
WiFi connection solutions include:
  • close all running APPs,
  • during APP install accept all permissions,
  • temporarily disable cellphone Data Plan Service,
  • disable smartphone Auto WiFi connect,
  • change WiFi Menu setting from 5 to 2.4 GHz may improve connection,
  • stronger WiFi networks may cause interference and weaken signal,
  • disable GPS to isolate problem.
Viofo A129 Duo Dash Cam Review: https://viofo-a129-duo-dash-cam-review.blogspot.com
 
Last edited:

c00ller

New Member
Joined
Apr 3, 2019
Messages
5
Points
3
It's ridiculous but you have to disable mobile data connection on your phone for the Viofo app to communicate with the A129 over WiFi.
 

BongyBoy

New Member
Joined
Dec 31, 2020
Messages
2
Points
1
I finally figured out how to fix the "internet may not be available problem". If you have an android this message will pop up. What you do is connect to the wifi, then it will say "internet may not be available"... What you do here is, on the upper left of your phone, click the back button twice to go two pages back....then after that, you open up your tabs on the bottom left of your phone then click the Viofo App and it should let you in
 

retiredat44

New Member
Joined
Dec 25, 2020
Messages
3
Points
1
Location
Oregon
Website
www.facebook.com
this is maddening,, I have been working with computers for decades, am retired now.. but this has beena real pia with my 129 viofo. Tring to connect with the wifi sucks... the camera seems to work pretty good, both front and reat take nice video and photos. No accidents' or any other issues to test the effectivness. The instructions on connections must have been writen in China and transposed by someone in Egypt. Or Mars, take your pick. Now with you guys here in these forums, I can take th einfo you gave and try to the 1000x time. Thanx all!

update,, yes, the wifi is a pia.. had to read these forum posts to figure it out... should just work without the issues of what needs to be turned on and turned off... now the cable must hasve an issue because the main power cable cannot be in fully or it loses contact. These forums are the most helpful for helping people. They should be in the maual.
 
Last edited:
Top