a129 pro duo kept telling to format exfat

bryan1996

New Member
Joined
Nov 23, 2021
Messages
9
Points
1
i'm new to viofo cam a129 pro duo out of box firmware 2.4,
brought it due to friend recommendation
been using it for 2 months with sandisk high endurance 256gb
at first the card was formatted in exfat and was in the device working fine
but then now whenever i insert any exfat card into the device, it will kept telling me to format it
and it will format it to fat32, tried sd memory card formatter, with overwrite format, still won't work
rest default setting - fail
reinstalling the firmware from 2.4 to 2.4 - fail

then i go to my friend, he was using samsung high endurance 128gb with exfat file system
when i inserted his card into my device, it tell me to format his card too !?
but when put back into his device it worked fine in exfat
if i put my sandisk sd card formatted with exfat file system into his device it WORKED !?

please advise
 

VIOFO-Support

Administrator
Joined
Jul 16, 2021
Messages
330
Points
28
Hello,

We would recommend doing the following steps in the meanwhile.

  1. Reflash the firmware and then default the settings in the menu and press the reset button on the side of the dashcam.
  2. Test the SD card referring to this link. If the card is no problem, please use SD Memory Card Formatter format once, and then format it again to FAT32 referring to this link.
 

bryan1996

New Member
Joined
Nov 23, 2021
Messages
9
Points
1
Hello,

We would recommend doing the following steps in the meanwhile.

  1. Reflash the firmware and then default the settings in the menu and press the reset button on the side of the dashcam.
  2. Test the SD card referring to this link. If the card is no problem, please use SD Memory Card Formatter format once, and then format it again to FAT32 referring to this link.
tried it, doesn't solve my problem, i think this is a bug or something
cause my card is working fine with exfat file system in my friend's device but not mine

i worry 10 min loop file might overload the fat32 file size limit, the workaround for this is to set the loop file to 5 min
will try exfat file system again when there is a new firmware, it is just a minor inconvenience
overall the dashcam is great

wish there is a feature to allow user to choose which file system (exfat or fat32) in the dashcam or the app
if there are more suggested solution do let me know

thanks
 
Last edited:

VIOFO-Support

Administrator
Joined
Jul 16, 2021
Messages
330
Points
28
tried it, doesn't solve my problem, i think this is a bug or something
cause my card is working fine with exfat file system in my friend's device but not mine

i worry 10 min loop file might overload the fat32 file size limit, the workaround for this is to set the loop file to 5 min
will try exfat file system again when there is a new firmware, it is just a minor inconvenience
overall the dashcam is great

wish there is a feature to allow user to choose which file system (exfat or fat32) in the dashcam or the app
if there are more suggested solution do let me know

thanks
May I know if you format the card on a windows computer or a Macbook? We recommend formatting the card on a windows computer.
 

SWoMP

Member
Joined
Jul 17, 2021
Messages
37
Points
8
Location
United Kingdom
I have an A129 Pro with two 256gb SDcards and I don't understand why you keep formatting your cards as exFat.
I was told from the start the system needs them to be FAT32 and with that, for me, they have been very reliable.
I use guiformat2 on a Windows PC to do a complete format when needed (not a "quick format") and the camera menu for a quick format when required.
The only downside to this is that when you insert a card into the PC Windows complains it it not formatted correctly. Ignore that and all the files can viewed, copied, etc.
Just remember not to use the Windows formatter as it cant do FAT32 on large cards.
You will need to download guiformat2 onto your PC.
 

bryan1996

New Member
Joined
Nov 23, 2021
Messages
9
Points
1
I have an A129 Pro with two 256gb SDcards and I don't understand why you keep formatting your cards as exFat.
I was told from the start the system needs them to be FAT32 and with that, for me, they have been very reliable.
I use guiformat2 on a Windows PC to do a complete format when needed (not a "quick format") and the camera menu for a quick format when required.
The only downside to this is that when you insert a card into the PC Windows complains it it not formatted correctly. Ignore that and all the files can viewed, copied, etc.
Just remember not to use the Windows formatter as it cant do FAT32 on large cards.
You will need to download guiformat2 onto your PC.
because fat32 are not designed to be used on large capacity cards
there is a file size limit max (4 gb) using fat32
exfat are optimized for continuous video recording
metadata checksum, there are more technical advantage details on how exfat works vs fat32...
but the most important, efficient file system overhead in cluster allocation resulting in faster writing and reading speed

the high speed 256gb SD cards you have, are tested using exfat
which have a guarantee to reach such speed using exfat
but if you use fat32 or other file systems;
some manufacturers will not acknowledge for not up to spec exchange (i will not name them)
especially with earlier sd card i can say with a certain most manufacturers will not acknowledge it

so why not use exfat if the dashcam support it?
 

bryan1996

New Member
Joined
Nov 23, 2021
Messages
9
Points
1
So the card has been formatted to FAT32. But it still doesn't work in your A129 Pro Duo with a 10 mins length loop recording. Unless it's changed to 5 mins.
no, i changed loop recording to 5min afraid that the file size might exceed 4gb with 10 min
the card at first was working fine with exfat in the dashcam regardless of loop length
but after 2 months i took the card out to inspect the files, my dashcam no longer want exfat...
everytime a sd card with exfat inserted into the dashcam, it will tell me to format it, and it will format to fat32

tried with 3 different sd card, with same result.
my friend is using a same model but his dashcam is fine with exfat, even with my exfat sd card
 

Capture Your Action

Well-Known Member
Joined
Feb 24, 2019
Messages
1,428
Points
63
no, i changed loop recording to 5min afraid that the file size might exceed 4gb with 10 min
the card at first was working fine with exfat in the dashcam regardless of loop length
but after 2 months i took the card out to inspect the files, my dashcam no longer want exfat...
everytime a sd card with exfat inserted into the dashcam, it will tell me to format it, and it will format to fat32

tried with 3 different sd card, with same result.
my friend is using a same model but his dashcam is fine with exfat, even with my exfat sd card
Are you and your friend using the same firmware version?
 

Capture Your Action

Well-Known Member
Joined
Feb 24, 2019
Messages
1,428
Points
63
Did you receive the camera with it's current firmware or did you update to it? If you updated it, be sure to manually default the cameras settings through the cameras menu, then press and hold the hard reset button on the side of the camera.
 

bryan1996

New Member
Joined
Nov 23, 2021
Messages
9
Points
1
Did you receive the camera with it's current firmware or did you update to it? If you updated it, be sure to manually default the cameras settings through the cameras menu, then press and hold the hard reset button on the side of the camera.
i received it with its current firmware 2.4
then did a firmware flashing to 2.4 after i encounter exfat problem
defaulted the dashcam setting many times still no fix

just few hours ago i did another firmware flash to 2.5 when i saw there is a new firmware release
reformatted the sd card did all the steps again, defaulted the setting in camera
it still tell me to format when a exfat sd card is inserted
i guess i need to accept the fact that the dashcam that i have don't play well with exfat

doing too much full format will do damage to all my sd cards
 

bryan1996

New Member
Joined
Nov 23, 2021
Messages
9
Points
1
and a new problem arise with firmware 2.5
screensaver in dashcam shows 30 seconds while in android app it shows 15 seconds

when you set screensaver setting using dashcam to 30 seconds it will stays as 30 seconds
but
using the android app screen saver setting 15 seconds = 30 seconds in dashcam setting
android app setting 3 seconds = 15 seconds in dashcam setting
android app setting 1 second = 3 seconds in dashcam setting

its mismatched
 
Top